Oracle 19.30: datapatch fails with ORA-01403 when applying OJVM patch 38523609

Whil applying the OJVM release update 19.30, patch 38523609 you may get the following error when running datapatch 38523609 (OJVM RELEASE UPDATE: 19.30.0.0.260120 (38523609))Patch 38523609 apply: WITH ERRORSlogfile: /oracle/app/oracle/cfgtoollogs/sqlpatch/38523609/28444968/38523609_apply_MYDB_2026Apr01_19_52_28.log (errors)-> Error at line 882: script javavm/install/bug35933540_apply.sql- ORA-01403: no data found- ORA-06512: at line 5 This error happens when JAVAVM component is not installed in the … Read more

Unsupported named object type for bind parameter at sqlpatch.pm line 6072

When running datapatch on your database you may encounter this error: Adding patches to installation queue and performing prereq checks…doneInstallation queue:For the following PDBs: CDB$ROOT PDB$SEED PDB1 PDB2 PDB3The following interim patches will be rolled back:37102264 (OJVM RELEASE UPDATE: 19.26.0.0.250121 (37102264))26749785 (PERF_DIAG NEED TO HAVE MORE CONTROL IN DICTIONARY FOR AUTO_STATS_ADVISOR_TASK)27605010 (DST UPGRADE SLOW (BEGIN_UPGRADE … Read more

ORA-39097 / ORA-39065 / ORA-21780 during Data Pump export — causes and solutions

expdp job is failing with the below error: ORA-39097: Data Pump job encountered unexpected error -21780ORA-39065: unexpected master process exception in DISPATCHORA-21780: Maximum number of object durations exceeded.ORA-06512: at “SYS.KUPM$MCP”, line 14382ORA-06512: at “SYS.KUPM$MCP”, line 12886ORA-06512: at “SYS.KUPM$MCP”, line 12565ORA-06512: at “SYS.KUPM$MCP”, line 15267ORA-06512: at “SYS.KUPM$MCP”, line 12619ORA-06512: at “SYS.KUPM$MCP”, line 15267ORA-06512: at “SYS.KUPM$MCP”, line … Read more

ORA-07445 [kkqjpdpvpd()+656]

If you are getting this error every minutes or so This error is because you have optimizer_features_enable set to 4 position instead of 3. When setting this parameter on Oracle Database 18c or later, you must specify three numeric values separated by periods, such as 18.1.0 or 19.1.0. https://docs.oracle.com/en/database/oracle/oracle-database/19/refrn/OPTIMIZER_FEATURES_ENABLE.html#GUID-E193EC9E-B642-4C01-99EC-24E04AEA1A2C Solution:alter system set optimizer_features_enable=’19.1.0′;

Shrink oracle tablespace

It is possible to resize a tablespace datafile is there is some free space at the end of the datafile. This is the quick and easy method. If you have data at the end of the datafile, you will need to move the objects so that segment will be recreated. View tablespace size with free … Read more

Q Processes take more and more memory

Q Processes take more and more memory and does not release the memory. pga_aggregate_limit=0 allows pga to grow unlimited hence the Q processes can consume all server memory. Temporary workaround is to reset the AQ slaves so that it is not necessary to shutdown/startup the db instance Queries to Monitor Q Processes. Check also that … Read more

High PGA memory consumption and high CPU usage is observed during the automatic maintenance task execution

Last, times, we noticed high cpu and memory usage on our database server. Top memory consuming process was some ora_j000_* process which are spawned as part of execution of auto task scheduler job . It was using also lots of swap. After reviewing, we found that the process was running “Optimizer statistics advisor” task name … Read more